Forum - Create/Update Vendor API

  • This topic has 5 replies, 2 voices, and was last updated 8 years ago by Anonymous.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #33974
    Anonymous
    Inactive

    Hello,

    Has anybody successfully used the REST APIs to Create and Update Vendors?

    I’ve been trying to use them on our sandbox but without success – I just get back an HTTP 500 internal server. Have been able to call other APIs OK – e.g. Get Vendors, Create PO Line.

    Just wanted to know if these APIs are functional yet, or if they are still in development?

    Thanks,

    Nick Jefferson, University of Manchester

    #35379
    Anonymous
    Inactive

    Hi Nick,
    Yes, the vendor APIs have just been released (December release). Before December they were still in Beta.
    If after Dec release is installed on your environment you still receive HTTP 500, please contact our support, or send me an email with your api-key (and a vendor code I can try to update), and I’ll give it a quick look.
    Thanks,
    Ori
    Alma API Team
    Ori.Miller@exlibrisgroup.com

    #35383
    Anonymous
    Inactive

    Hi Ori,

    Thanks for your reply. We do have the December release installed on our Sandbox. I’ve tried the Create Vendor request again using the sample inputs from here:
    https://developers.exlibrisgroup.com/alma/apis/xsd/rest_vendor.xsd?tags=POST#Samples

    I find that the XML sample succeeds but the JSON sample fails with an HTTP 500 response.

    Before I contact support, please could you confirm whether or not the currently released Create Vendor API supports JSON, and that the JSON sample on the above web page is valid?

    Thanks for your help,
    Nick

    #35385
    Anonymous
    Inactive

    Hi Nick,
    We are already aware that there are issues with JSON in our Vendor API. We will do our best to fix it for the Jan release.
    In the meantime, please accept our apologies, and if possible use the XML format.
    Thanks,
    Ori

    #35386
    Anonymous
    Inactive

    Hi Ori,
    Thanks for confirming there are some issues with the JSON. No problem, it’s not urgent so I’ll wait for the January release to see if there is a fix.
    Best Wishes,
    Nick.

    #35402
    Anonymous
    Inactive

    Hi Ori,
    Just wanted to confirm that JSON objects in the Vendor API seem to be working OK now in the Jan 2015 release. Thanks for the fix 🙂
    Best Wishes,
    Nick

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.