Forum - “Sorry, but the page you’ve been looking for can’t be found” on NA01

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #68379
    Central Oregon Community College 01ALLIANCE_COCC
    Participant

    Our Alma instance is on na01.alma.exlibrisgroup.com, and we have no sandbox. I was able to use the CLI a few weeks ago to develop a cloud app, but today when I try to run the CLI again, I get the error “Sorry but the page you’ve been looking for can’t be found. Please Contact your Library Support or Ex Libris HUB for additional information.”

    When I change the configuration to proxy a different hosted server–like the sandbox in Europe in the Getting Started documentation, sandbox02-eu.alma.exlibrisgroup.com–the error changes to the expected “Illegal Institution – Please try again.”

    Is the NA01 server returning the “Sorry” error, or is there something in the my configuration or CLI installation that can be fixed?

    #68384
    Josh Weisman
    Keymaster

    Hi there. If you set your env property in the config.json file to this value, it should work:
    https://na01.alma.exlibrisgroup.com/institution/01ALLIANCE_COCC

    #68390
    Central Oregon Community College 01ALLIANCE_COCC
    Participant

    Hello Josh,

    That is the URL I’m using in the env property. Here’s a screenshot with both the command-line window and the “Sorry” result: https://drive.google.com/file/d/1Bp7_yF3OlImUokRVLSopAnDXbX_AJL8v/view?usp=sharing

    When I try other Alma URLs in the env property, like https://suny-buf-psb.alma.exlibrisgroup.com/institution/01SUNY_BUF found in another thread, those libraries’ login screens successfully appear.

    When I deliberately mis-type the URL, I get the error “Error occured while trying to proxy to: localhost:4200/mng/login”. So this tells me when I use the URL that should be correct, my development server is successfully proxying na01.alma.exlibrisgroup.com, but the content returned is the “Sorry” message.

    Another strange thing that happens: if after seeing the “Sorry” message, I modify the URL to just localhost:4200, I see the main contents of the cloud app all by itself: https://drive.google.com/file/d/1DvnaU-yuJk0mt0f8gbQLACPmuKH1yYQK/view?usp=sharing

    -Tamara

    #68422
    Josh Weisman
    Keymaster

    Hi Tamara. We were able to figure out where this was coming from on our side. You should be good to go.

    Let us know how it works out. Thanks.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.